Server IP & Memory Usage Display

..
server-ip-memory-usage Banner

Contributors: apasionados
Donate link: http://apasionados.es/
Author URI: http://apasionados.es/ Tags: memory, memory-limit, ip, ips, admin, adress, php, server, info
Requires at least: 3.0.1
Tested up to: 5.2
Requires PHP: 5.3 Stable tag: 2.1.0
License: GPLv2 or later
License URI: http://www.gnu.org/licenses/gpl-2.0.html

Show the memory limit, current memory usage and IP address in the admin footer.

Description

This plugin displays the memory limit, current memory usage, WordPress Memory Limit, IP address and PHP version in the admin footer.

There are four features we love:

1) You can easily see in the admin footer the IP where this WordPress installation is running. Very useful if you have many WordPress installations across several servers and IP addresses.

2) The memory usage and total available memory to the WordPress installation is shown in the admin footer. If memory usage is over 75% the percentage is shown in a light red and if the memory usage is over 90% the percentage is shown in red. So you can allways control with one look if there is enough memory available or if action has to be taken. It also displays the WordPress memory limit to give you more information.

3) Besides the IP address and the memory you can also see the PHP version and the type of Operating System where it's running.

4) You can translate the plugin into your own language. So far English and Spanish translations are included. Just translate the .po file in the /lang/ folder.

What can I do with this plugin?

This plugin displays the total memory, used memory, percentage of used memory, WP memory limit, the IP address and the PHP version in the admin footer.

What ideas is this plugin based on?

We had been using the WordPress plugin WP-Memory-Usage but didn't want the dashboard widget and needed the IP address displayed. We also didn't like that the plugin could not be translated.

This is why we decided to create a new plugin that solves these two explained needs: IP address display and ability to translate.

System requirements

PHP version 5.3 or greater.

Server IP & Memory Usage Display Plugin in your Language!

This first release is avaliable in English and Spanish. In the "lang" folder we have included the necessarry files to translate this plugin.

If you would like the plugin in your language and you're good at translating, please drop us a line at Contact us.

Further Reading

You can access the description of the plugin in Spanish at: Server IP & Memory Usage Display en español.

Screenshots

Plugin README Parser: Could not find screenshot-1 image file

Plugin README Parser: Could not find screenshot-2 image file

Plugin README Parser: Could not find screenshot-3 image file

Installation

  1. First you will have to upload the plugin to the /wp-content/plugins/ folder.
  2. Then activate the plugin in the plugin panel.
  3. Now the information regarding memory limit, current memory usage, IP address and PHP version is displayed in the admin footer.

Please note that the plugin should not be used together with other plugins with similar funcionalities like: WP-Memory-Usage.

Please use with WordPress MultiSite at your own risk, as it has not been tested.

Frequently Asked Questions

Why did you make this plugin?

We couldn't find a plugin that would give us the functionality we were looking for: 1) IP address display in footer of WordPress admin. 2) Total memory and memory usage displayed in the admin footer, without dashboard plugins. 3) Easy translation of the plugin into other languages. So far English and Spanish translations are included.

How can I remove Server IP & Memory Usage Display?

You can simply activate, deactivate or delete it in your plugin management section.

Are there any known incompatibilities?

The plugin should not be used together with other plugins with similar funcionalities like: WP-Memory-Usage. Please use with WordPress MultiSite at your own risk, as it has not been tested.

Are there any server requirements?

The PHP version should be at least 5.3. If PHP version is lower than 5.3 there is an error message shown and plugin is not activated.

Do you make use of Server IP & Memory Usage Display yourself?

Of course we do. That's why we created it. 😉

Contact

For further information please send us an email.

..
On github.com
https://github.com/wp-plugins/server-ip-memory-usage
Developer
https://github.com/wp-plugins?tab=repositories
..
Source: server-ip-memory-usage
Revision: https://plugins.trac.wordpress.org/log/server-ip-memory-usage/
An error has occurred, which probably means the feed is down. Try again later.
..

Leave a Reply

Your email address will not be published. Required fields are marked *

Top